ECS Centos 执行yum update -y后无法启动lampp(xampp)并报错libc.so.6的解决方法

前天给公司的阿里云ECS服务器(Centos)执行了yum update -y命令(周常嘛),更新了啥我记不清了,反正平时也不怎么用yum装东西。

只是这次更新完后,今天重启服务器后另XAMPP崩了,大晚上的,本来想开车(美国卡车模拟,有朋友玩的可以问我要Steam一起开车车),唉……

f3

错误信息如下:

先用命令 ldd /bin/ls 看一下lib的情况,结果是没什么问题,该有的都有。

通过关键字和lib名Google了一圈,找到一个可行的方法:https://viewsby.wordpress.com/2013/02/01/lampp-error-while-loading-shared-libraries-libc-so-6-xampp-centos/

该方法中提到的lampp文件跟我的lampp文件比较起来,较旧,所以Line Number和语句都有很大差距,基本没法对照。

但是文章的主要意思是说这份文件在根据服务器的版本做判断!(划重点)

看了下我服务器的版本是CentOS release 6.9 (Final)。

所以我决定打开服务器的lampp文件,结合服务器的版本进行调试。

f2

然后执行启动命令/opt/lampp/lampp start ,正常启动!

如果你也是执行yum update 后,再重启了服务器后遇到这样的问题,使用这个解决方法就可以。

如果是其他问题,我暂时未遇到。

原创文章,转载请注明: 转载自konakona

本文链接地址: ECS Centos 执行yum update -y后无法启动lampp(xampp)并报错libc.so.6的解决方法

团哥

继续玩我的CODE,让别人说去。 低调,就是这么自信。

You may also like...