konakona
让PHPStorm支持Laravel框架语法
让PHPStorm支持Laravel框架语法

2014.9.14 Tips:

具官方消息,Phpstorm8中将加入laravel的支持(目前beta版已支持部分blambe语法)!

 

在PHPStorm中开发Laravel项目时经常会遇到无法识别Laravel的各种类、命名空间、方法变量等等,很不爽。这使得IDE不那么友好,我们可以使用一份php文件去引导PHPStorm提供Laravel的语法提示和自动补全功能。

首先下载下面这份文件,将它解压缩出来的一份php文件放在与app平级的目录下,此时观察你的PHPStorm,试着输入“Event::li”是不是出现了相关联的方法呢?

_ide_helpers.php

ok,问题解决。

还有一些其他方法,感兴趣的朋友可以看看这里:https://github.com/barryvdh/laravel-ide-helper

赞赏
https://secure.gravatar.com/avatar/3b712b34a0e1b689cfb524c9c6bcdc47?s=256&r=g

团哥

文章作者

继续玩我的CODE,让别人说去。 低调,就是这么自信。

发表评论

textsms
account_circle
email

konakona

让PHPStorm支持Laravel框架语法
2014.9.14 Tips: 具官方消息,Phpstorm8中将加入laravel的支持(目前beta版已支持部分blambe语法)!   在PHPStorm中开发Laravel项目时经常会遇到无法识别Laravel的各种类…
扫描二维码继续阅读
2014-08-07